Actualité Internet et DNS

Latest Posts

DNS lookup failed or very, very, slow.

Everyone thought it was bandwidth utilization but we brought in a new 50/10 circuit (this issue wasn’t the deciding factor) and it may have gotten worse.

Symptoms: Pages load slowly, I mean 56k slow but only sometimes, but frequently, or pages load halfway but on refresh almost instantly.

Since the latest chrome update it actually gives the « webpage is not available » error before eventually loading.

Environment: Windows – both DC and PDC are 2012, all workstations are W7. Only one domain in forest.

PDC refers to it’s self as preferred DNS server:

DC refers to PDC as Preferred DNS and it’s self as Alternate DNS.

Gateway points toward ISP’s DNS currently but I’ve changed that around in the past to see if that was the issue. No URL filtering or monitoring set up, DNS Lookup and Proxy are enabled.

Workstations DNS set to PDC, DC, and Gateway.

Another thing that makes me think it’s DNS related is that down and up speeds are normal, it’s only page loads that are slow.

Servers are showing no DNS errors. I’ve tried it with the AV disabled but issues persisted.

Any help or a point in a direction is appreciated.

submitted by convulsus_lux_lucis
[link] [17 comments]

Powered by WPeMatico

DNS help with a web spider

I am running a simple PERL web spider at home on a linux computer. When running 20 or more threads I tend to take down my router. This has been something i’ve looked into from time to time over the years.

I use dd-wrt and when the network starts to really slow down there are thousands of connections – with 3/4 of them being UDP to whatever DNS servers I try at the time …

Am I getting rate limited by DNS from doing too many lookups? Is there a way around this? I imagine hosting my own DNS server would be a nightmare but im ok with it - as the records im looking up are not super critical…

submitted by mxtszlpc
[link] [3 comments]

Powered by WPeMatico

Made a DNS change for the company website and everyone on the internet can see the change.. EXCEPT for any computer within our office. What's going on? It's been more than 24 hours.

I was on a client site and made companydomain.com point to a new server, which worked almost immediatly. Everyone else sees that companydomain.com resolves to a new IP address EXCEPT for everyone in our office. We’re all behind the same router, so I restarted the router in case it was caching an old value.

I’m work with DNS from time to time, but have never seen this happen. People are getting angry and I have zero idea where to begin.

Any pointers? Thank you!

submitted by bent_my_wookie
[link] [11 comments]

Powered by WPeMatico

Fedora RPM specs for pdnsd and dnscrypt-proxy

If you happen to be looking for RPMs for pdnsd and dnscrypt-proxy on Fedora, you can use my RPM specs to build RPMS to install on your Fedora Linux machine. I’ve tested them to work on Fedora 19. The original pdnsd SPEC has a bug that causes rpmbuild to fail and the original dnscrypt-proxy SPEC lacks systemd support, so there’s no service to start and stop.

PDNSD is a basically a local caching proxy.

DNSCrypt proxy allows you to connect to query OpenDNS server and mitigate DNS attacks e.g. when behind the GFW.

https://github.com/jchia/rpm-specs

submitted by Syncopat3d
[link] [comment]

Powered by WPeMatico

Trying to figure out how to link a subdomain to a specific port.

Hey there. I run a minecraft server and I’m having a bit of issues figuring out the best approach to accessing ports using either subdomains or ports at the end of a url.

With both my servers they’re using an SRV record, so those are fine. However, with my admin panel and dynmap page, I can’t seem to get it set up either way.

I’d assumed that I could set up an iframe redirect, but I don’t see this in my Cloudflare DNS control panel. Googling iframe redirect cloudflare brought me to « page rules » but having gone through it, I don’t see anything useful. I can create a redirect but it just leads to the exposed IP address of the server.

I understand that I can create a reverse proxy server, but I am having the issue of not being able to locate the .htaccess file on Ubuntu 14.04 LTS and not understanding how to deal with creating a subdomain correctly at that point.

I’m guessing that I’d have to set up another SRV record and that the reverse proxy would deliver the html as expected? My understanding is that SRV records can’t process HTML and browsers would be incompatible with that information. I’m probably screwing this up very badly.

submitted by PutoGonzalez
[link] [4 comments]

Powered by WPeMatico

DNS at home

Maybe I’m creating my own problem but I’m kind of stuck. I have a handful of hosts at home and a 64 address DHCP block for which I have a TLD setup on a Solaris machine. nslookup from the Windows clients always works (it always asks the primary DNS server, the Solaris machine), but when I have a second DNS server listed sometimes the web browsers don’t properly look up internal hosts (e.g., the router or the printer), I get host name undefined errors. To resolve the problem I removed the secondary DNS server from all the windows clients (one of Google’s public DNS servers) and now everything works. Which would be fine but sometimes I have to take the Solaris machine down and for that time period no web surfing happens and that’s not good for SAF*…

Is it normal behavior for the resolver library (in Windows?) to round robin the DNS servers? When I run snoop on the Solaris box I see queries come in and get resolved, then suddenly nothing and that’s when that client’s web browser returns a host not found, it appears that my DNS server was not queried.

I wanted to setup a secondary name server in house, preferably on the router (if it’s down there’s no surfing anyway) but it doesn’t seem like any of the router firmwares support being a (secondary) DNS server (at least not by default). Am I missing something about the router firmwares? Am I configuring something on my Windows clients wrong?

My router is a NetGear WNR3500L, if I reserve IPs for various hosts and set the Windows client to use the router as a DNS server will it return addresses from names?

*Spouse Acceptance Factor

submitted by uprightHippie
[link] [6 comments]

Powered by WPeMatico